Error pulling image of websocket-proxy from docker hub

I’m trying to setup external websocket-proxy server for rancher server. For that I tried to pull websocket proxy image from docker hub, but it shows error. I already have rancher server up and running. I have api.crt generated from that running rancher server in current directory.

sudo docker run -d -v $(pwd)/api.crt:/api.crt websocket-proxy -jwt-public-key-file=/api.crt -listen-address= -cattle-address=rancher_ip:8080

Unable to find image ‘websocket-proxy:latest’ locally
docker: Error response from daemon: pull access denied for websocket-proxy, repository does not exist or may require ‘docker login’.
See ‘docker run --help’.

I thought websocket-proxy image doesn’t exist, so I tried other websocket-proxy variations.

sudo docker run -d -v $(pwd)/api.crt:/api.crt rancher/websocket-proxy -jwt-public-key-file=/api.crt -listen-address= -cattle-address=rancher_ip:8080

docker: Error response from daemon: oci runtime error: container_linux.go:265: starting container process caused “exec: “-jwt-public-key-file=/api.crt”: stat -jwt-public-key-file=/api.crt: no such file or directory”.

How to resolve this error?