ESXi Replacement

Greetings and thank you for reading,

I am currently trying to simulate a fresh install on new machine and I believe I missing a step here. Could someone possibly provide some insight into what I am doing wrong here?

I start with this guide:

  • Run sudo mkfs.ext4 -L RANCHER_STATE /dev/sda

Then proceed to:

The step that I get stuck on is after I have created the ssh key and built my cloud-config.yml (I have placed it both in the root and in /var/lib/rancher/conf/), but I get the error of “No install type specified…defaulting to generic \ cp: can’t stat ‘cloud_config.yml’: No such file or directory” when I try to run rancheros-install -c cloud_config.yml -d /dev/sda

What I am trying to accomplish is this with is the following:

System Docker
\\\\\\\\ System Containers

\\\\\\\\ RancherVM
\\\\\\\\\\\\\\ Windows Server 2012

\\\\\\\\ User Docker
\\\\\\\\\\\\\\ Linux instances

You do not need to do sudo mkfs.ext4 -L RANCHER_STATE /dev/sda before installing to disk.

The cloud config file should be in the directory where you are running your command.

Hope that helps move you along!


Thank you for the information. I placed my file in ./root (not sure if that is permitted) and ran this command as root:
rancheros-install -c cloud_config.yml -d /dev/sda

I got this reply:
No install type specified…defaulting to generic
cp: can’t stat ‘cloud_config.yml’: No such file or directory

So I tried running:
rancheros-install -c cloud_config.yml -d /dev/sda -t rancher/os:v0.3.3 remote

And now I got:
cp: can’t stat ‘cloud_config.yml’: No such file or directory

I tried putting a second copy into:

And ran:
rancheros-install -c /var/lib/rancher/conf/cloud_config.yml -d /dev/sda -t rancher/os:v0.3.3 remote

rancheros-install -c /var/lib/rancher/conf/ -d /dev/sda -t rancher/os:v0.3.3 remote

And various others, but I am not able to get this command to show:
All data will be wiped from this device
Partition: true
DEVICE: /dev/sda
Are you sure you want to continue? [yN]

My cloud_config.yml (I have a real key in the file):

// ssh_authorized_keys:
//// - ssh-rsa AAAAB3N… user@host

// network:
// dns:
//// nameservers:
//// -
//// -
// interfaces:
// eth*: {}
// eth0:
//// match: eth0
//// address:
//// gateway:
//// mtu: 1460
// lo:
//// address:


There are a couple of issues with your installment.

In your cloud-config.yml, you’ll need to place the network key underneath the rancher key for RancherOS to parse through it and apply the networking changes.

I usually just save my cloud config in the directory that I am logged in as a the rancher user. I wouldn’t recommend saving it in /var/lib/rancher/conf because that’s where rancherOS tends to save cloud config information after being processed. Have you tried logging into RancherOS as the rancher user and just creating the cloud config file in the directory that you log in and running the command?

As for the commands, the options are not being used correctly. It makes me realize that we should make the docs more clear on how to use versions. :slight_smile:

It should be -v instead of -t when setting a version. It should also be -v v0.3.3 when you pass in the version. But you shouldn’t need to pass in the v0.3.3 version because that’s the latest and current default.


Thank you very much for the prompt reply! Per your instruction, if I read them correctly, I have done the following and received the following results.

Reorganized my cloud_config.yml (noticed you used a “-” and I am unsure if that makes a difference) to have the network config first. I placed the file in “/home/rancher” and if this isn’t what you mean, let me know.

I then ran the command: sudo rancheros-install -c could_config.yml -d /dev/sda -v v0.3.3
and got the response of No install type specified…defaulting to generic
cp can’t stat ‘could_config.yml’: No such file or directory

What did I miss this time?

That message, and the previous ones, means it’s not finding the .yml file, so it doesn’t really matter what is in the file until the command is actually getting to read it. In the last one “cloud” is spelled wrong in the command…

That was a typing error in the reply. I would upload the image, but “Sorry, new users can not upload images.”


I’ve updated so that you can add photos.

Can you do a screen shot of these commands?

sudo rancheros-install -c cloud_config.yml -d /dev/sda