/etc/inputrc vs .inputrc and bash autocompletion problems


OS: Open Suse 11.4 64 bit running inside Virtualbox.

I am following the link

to make bash behave like cmd.

It worked well in Arch Linux.

Recently I felt like I want to put this in Open Suse 11.4 and put the changes
to [COLOR="#0000FF"].inputrc[/COLOR] and restarted the box (permissions of .inputrc = 755)

[INDENT][FONT=Courier New][SIZE=4]set completion-ignore-case on

Ignore case when doing completion

set mark-directories on

Completed dir names have a slash appended

set visible-stats on

List ls -F for completion

“\C-i”: menu-complete

The TAB completion [COLOR="#FF0000"]DID NOT work[/COLOR].

Tried a lot but no luck.

I then moved the above section to /etc/inputrc and restarted the machine

and VIOLA the tab completion works.

But in my office env, I dont have the luxury of modifying the [COLOR="#0000FF"]/etc/inputrc[/COLOR] and only [COLOR="#0000FF"].inputrc[/COLOR] will help.

Any ideas/suggestion would help.

savithari wrote:

OS: Open Suse 11.4 64 bit running inside Virtualbox.[/color]

This forum is for Suse Linux Enterprise Server. If you’re asking about
OpenSUSE you should be posting in one of these openSUSE forums where
Members with the appropriate expertise will be pleased to help you.

Kevin Boyle - Knowledge Partner
If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below…