Firefox won't run in XEN VM

As this is related to an inability to run Firefox in a XEN VM environment, I hope this problem is in the right forum. The platform is SLES11SP4 on both the host and the 3 XEN VMs. Firefox runs OK on the host.

If I try to start Firefox on one of the VMs, nothing happens, after the timer disappears. If I try to run it in a terminal session, I get the following (even in safe mode):
[24126] ###!!! ABORT: js::jit:InitProcessExecutableMemory() failed: file /usr/src/packages/BUILD/mozilla/XPCOMinit.cpp, line 709
that is repeated, and then it says:
Segmentation fault

Any suggestions, please?



It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

These forums are peer-to-peer, best effort, volunteer run and that if your issue
is urgent or not getting a response, you might try one of the following options:

Be sure to read the forum FAQ about what to expect in the way of responses:

If this is a reply to a duplicate posting or otherwise posted in error, please
ignore and accept our apologies and rest assured we will issue a stern reprimand
to our posting bot…

Good luck!

Your SUSE Forums Team

Hi Jerome,

as no-one else tried to answer, here come some shots into the dark:

  • have you tried running Firefox with a fresh profile, or probably by starting it into “Profile Management” mode (“firefox --ProfileManager”)? The latter will tell if it’s a profile-related problem, as Firefox will first prompt you which profile to use. If that window appears, the problem is probably related to the currently used profile and you should start with a fresh one.

  • did you verify that you have write access to the current home directory and that there’s still free space available in /tmp, /var and the home directory? Sometimes, obscure errors like the one you’re seeing result from out-of-disk-space conditions confusing the software.

  • if nothing else help, try running “rpm -V all” as root, to verify the files of all packages. Maybe some code file got corrupted somehow, and the “RPM verify” will tell you. Please note that you will also see a number of “false positives”, as config files will be reported, too. I strongly recommend to consult rpm’s man page regarding the flags that command will report with its findings.