HA cluster with own certificate


I’ve been loosing my faith trying to launch a 3 nodes HA with external DB with my own wilcard certificate.
As said here https://github.com/rancher/rancher/issues/5311, I’ve injected my certificate into the rancher-ha.sh setup file, and run the installation.
On the management User-stack, I’ve ‘go-machine-service’ and ‘rancher-compose-executor’ containers trying to run 2 instances : one of each failed with errors.

Logs on the rce :

time="2016-09-07T10:25:05Z" level=info msg="Listening on" 
time="2016-09-07T10:25:05Z" level=info msg="Forwarding setup to: :80" 
time="2016-09-07T10:25:06Z" level=info msg="Listening on port: 80" 
time="2016-09-07T10:25:06Z" level=info msg="Starting rancher-compose-executor" version=v0.8.6 
time="2016-09-07T10:25:06Z" level=fatal msg="Unable to create event router" error="Get https://XXXX/v1: EOF" 
time="2016-09-07T10:25:06Z" level=fatal msg="exit status 1" 

Logs on the gms :

time="2016-09-07T10:32:17Z" level=info msg="Listening on" 
time="2016-09-07T10:32:17Z" level=info msg="Forwarding setup to: :80" 
time="2016-09-07T10:32:18Z" level=info msg="Listening on port: 80" 
time="2016-09-07T10:32:18Z" level=info msg="Setting log level" logLevel=info 
time="2016-09-07T10:32:18Z" level=info msg="Starting go-machine-service..." gitcommit=v0.31.7 
time="2016-09-07T10:32:18Z" level=info msg="Waiting for handler registration (1/2)" 
time="2016-09-07T10:32:18Z" level=fatal msg="Exiting go-machine-service: Get https://XXX/v1: EOF" 
time="2016-09-07T10:32:18Z" level=fatal msg="exit status 1" 

If I let the default configuration (auto generated certificate), all is working good. But I need my own certificate to deal with extra third-parts, like AWS or Cloudflare.
Am I the only one in this issue ?

My config:
Rancher v1.1.3
Cattle v0.165.8.1
User Interface v1.1.12
Rancher Compose v0.8.6

Is the cert installing ok? If you validate it with, https://www.sslshopper.com/ssl-checker.html does it show up correctly?

This could also be an issue with the host URL you set when you initially setup the Rancher HA environment. I’ve found that the go-machine-service and the rancher-compose-executor don’t update their URL’s if you change the rancher URL after setup.