Helm Tiller not installing through Gitlab

Hello there !

I’m trying to setup Gitlab / Kubernetes using Rancher, and i’m actually following this topic : https://rancher.com/blog/2019/connecting-gitlab-autodevops-authorized-cluster-endpoints/

Perhaps, when it comes to helm install, here is the result :

i then tried to read logs but they do not help me a lot :

> kubectl logs install-helm  -n gitlab-managed-apps
+ helm init --tiller-tls --tiller-tls-verify --tls-ca-cert /data/helm/helm/config/ca.pem --tiller-tls-cert /data/helm/helm/config/cert.pem --tiller-tls-key /data/helm/helm/config/key.pem --service-account tiller
Creating /root/.helm 
Creating /root/.helm/repository 
Creating /root/.helm/repository/cache 
Creating /root/.helm/repository/local 
Creating /root/.helm/plugins 
Creating /root/.helm/starters 
Creating /root/.helm/cache/archive 
Creating /root/.helm/repository/repositories.yaml 
Adding stable repo with URL: https://kubernetes-charts.storage.googleapis.com 
Adding local repo with URL: 
$HELM_HOME has been configured at /root/.helm.
Error: error installing: the server could not find the requested resource

Does anyone already faced it ?

I’m stuck on it, just can’t figure out what’s going on …

Thanks by the way !


I had to install a newer version (v2.16.1) of Helm. I was using 2.14.x.

Hi there !

thank you, one additionnal question, could you provide me a way of doing manual install in rancher ?

I tried from “kubectl” command line in my cluster overview but i couldn’t install anything from here, except using k8s commands. Is it to install on the node ?

I’m sorry, just discovering, and i couldn’t find myself after researchs

Thanks btw !