Helm - no repositories to show

I just tried to upgrade a Rancher 2.2.9 installation - that has been upgraded multiple times in the past and was surprised with:

helm repo list
Error: no repositories to show

As I stated above, this system has been upgraded multiple times in the past… so I’m at a loss at what is happening.

I took a chance to re-add the repositories, but when I went to upgrade I get:

$ helm get values rancher
Error: release: not found
$ helm upgrade rancher rancher-stable/rancher --set hostname=<fqdn here>`
Error: UPGRADE FAILED: "rancher" has no deployed releases

I have verified that kubectl is talking to the right cluster.

BTW, the cluster seems seems to be working well - the web interface is working fine.

Thanks.

are you using the correct kube config file? the one that points at the Rancher HA local cluster.

kubectl seems to be talking to the right cluster… the only thing on this cluster is Rancher…

kubectl get nodes
NAME            STATUS   ROLES                      AGE    VERSION
172.20.10.101   Ready    controlplane,etcd,worker   179d   v1.13.5
172.20.10.102   Ready    controlplane,etcd,worker   179d   v1.13.5
172.20.10.103   Ready    controlplane,etcd,worker   179d   v1.13.5

hmm,

do you have tiller installed in a different namespace (and not kube-system)? That’s my only other idea.

Should be the same. I’ve upgraded this cluster multiple times in the past… Given it is running rancher it has been kept pretty clean… and hands off. We have two other clusters on different blades that are being managed by this rancher instance.

Is there a clean way to reload or reset tiller?

Oh, crud…

$ helm version
version.BuildInfo{Version:"v3.0.0", GitCommit:"e29ce2a54e96cd02ccfce88bee4f58bb6e2a28b6", GitTreeState:"clean", GoVersion:"go1.13.4"}

I believe helm was upgraded on another computer (not on the server) - is there a clean way to go back to v2 with the old configuration?

Helm is just a binary, so you should be able to download the older version of Helm from GitHub.

Thanks… I didn’t want to take any chances… Downgrading to v2 worked.

Thanks for everyone’s help!