High availability setup with Round Robin DNS

Hi, we are setting up a test environment, we rancherOS on 3 bare metal servers, and have setup percona cluster on each. Next we successfully launched rancher on one node. We dont have an external load balancer, we have set up round robin dns for the 3 machines to be accessible from a single domain. However, this seems to be a problem when trying to run the rancher-ha.sh script. The logs are just spewing:

Can not launch agent right now: Server not available at" component=service

Is it simply not do-able? or is there a work around or indeed is something else a miss?

all latest code. (v0.5.0 // rancher/server:v1.1.0)

I have tried editing the rancher-ha.sh script to add -p 8080:8080 -p 443:443 -p 18080:18080 to the docker run command but this made no change. Im not quite sure what the route cause is?

I have also tried setting docker run -e CATTLE_AGENT_IP=host_ip… and export CATTLE_AGENT_IP=host_ip both in rancher_ha.

I also tried setting the CATTLE_HA_HOST_REGISTRATION_URL to include the :8080 and to run on http since round robin would not be doing the same port forwarding as a load balancer.

I have spent two days solid tearing this up and down it is so frustrating.


1 Like

I am also experiencing the same exact issues… And have tried all of the above steps with no luck…

We don’t recommend using round robin DNS for any real HA setup. It might work but wont be adequate for a large number of reasons. Any reason why you wouldnt be using something designed for load balancing, like HA Proxy, ELB, etc…?

For me its just a test environment, I have 3 bare metal servers to cluster, and it saved me placing another piece of hardware in front of them.

What are the large number of reasons? In summary format if you don’t mind taking the time?

My issues stopped when i switched to rhel7.2… I was previously using centos7

1 Like