How to fix nameserver setting permanently


I need to refer the external DNS server.
Then I checked “/var/run/netconfig/resolv.conf”, and nameserver is “”.

I changed the name server address to the external DNS server’s one.
I can resolve the hostname by the external DNS server.

But after rebooting, the setting went to back the before value(
Could you tell me How to fix nameserver setting permanently?

Best regards,

Did you run the command as indicated in the file netconfig update -f? Or if using wicked, then set via YaST Network Settings in the Hostname/DNS tab.

Thank you for advice.
The problem is solved.

The wicked.service is used.

I set the DNS server by yast(following command).
yast dns edit nameserver1=

After rebooting, I confirmed that the DNS server is reflected to /etc/resolv.conf.

Best regards,