Name resolving does not work after update from 11 to 11 sp1

I had an quite well working system that I decided to update from SLES 11 x86 to SLES11 SP2 x86, the server is an host on an VmWare ESX 3.5 server.

I tried the Yast route with no luck so I used the zypper procedure to go to SP1 intending on SP2 following that, from here that after few hitches resolved by disabling the CD/DVD respiratory ran with out error.
After an required reboot name resolution is lost My server is unable to resolve names from external DNS. I’m running bind DNS server on this server which serves names normally bur is not able to look up names from non hosted domains. (host not resolving names).
The DNS as well as host config in Yast are both pointed to my ISP DNS that I can ping an dig every domain from.
My DNS on this host replies nomaly from the outside
After spending approx 10 hours chasing this ghost Googleing and reading testing different solutions I’m totally stumped.
son far I have tried to use older methods that used to work like Resolve.conf etc but it seems that thing called netconfig is taking the charge of things all the time an little ore no way of influencing how it behaves.
Reading documentation is not helping me at all where I just need to know what foe ie. what and why is DNS policy see below documented explination.
Defines the DNS merge policy.
The type of the forwarder type to configure. Valid settings are “resolver”, “bind” and “dnsmasq”. The default setting is “resolver” activating the “dns-resolver” module.
List of DNS domain names used for host-name lookup.
List of namserver IP addresses used for host-name lookup.

How can one set the DNS for the host, I need to resolve names merging that with unknown stuff is not needed, just old fashioned name resolving.
Is there any one that can help me with even just an solid search hint for Google or any good idea ?

I do apologize but my server is supposedly set to use ifconfig not netconfig that seems not to be installed how ever least of the settings pertaining to name resolution seem to make sense an I’m getting dialogue all the time form yast that netconfig did this or that bu did not save over an manually edited file of mine?
Ho does this add up ?

Hi martolvan,

getting DNS to work should be easy, but I didn’t grab your setup yet. Am I right with the following description:

You have upgraded a SLES server to SLES11SP1. On that server, there’s a DNS server (“named”) running which serves some own domains and is used to resolve all other requests by forwarding such queries to the ISP name server and handles external DNS queries for your DNS domains.

Before the upgrade, you were able to resolve all local/internal and external queries. After the upgrade, resolving external queries still works, resolving internal queries for internal zones works, resolving internal queries for non-local domains doesn’t work.

So far correct?

  • On the server, does /etc/resolv.conf point to localhost and/or to it’s “LAN IP address”?
  • Does the name server configuration contain the proper “allow-recursion” and “forwarders” statements?
  • Anything in syslog or named trace concerning this?

It might be helpful to see the related parts of you name server configuration and /etc/resolv.conf.


PS: netconfig can be thought of as the general network auto-configuration framework on your server, while “ifconfig” is one of the available command tools to actually configure network settings of a device. Not seeing the mentioned error message I can only guess, but most probably YaST and its configuration back-ends detected manual changes of some config file (maybe because of the update process, maybe because of your recent actions to resolve the difficulties) and avoids overwriting these changes. You then ought to check the mentioned file and take appropriate action.