How to force pvc containers to machine_type=data


#1

I have cluster where is different type of machines and I could not figure out how to force longhorn pvc containers to run only on machine with annotation machine_type=data

Thanks in advance!


#2

If you meant by don’t schedule replicas to machine without a certain tag, Longhorn hasn’t supported that yet. In the meantime, you can go to Nodes and disable scheduling for some of the nodes manually.


#3

Yes exactly, I found how you can use UI to disable scheduling. Thanks for a reply!

Tagging would be really helpful in situations where you provision machines with different resources…