Ingress / TLS with wildcard cert

I loaded a wildcard certificate in Rancher - *

I created an Ingress and if I enter some specific addresses in the TLS hosts section (e.g., they get the cert correctly. But the default backend for example, end up with a K8s generated cert. And any other sub-domain not specifically listed as a host in the TLS section also doesn’t get the correct cert.

How to tell Ingress to use the wildcard certificate for everything. In the TLS section, if I tried entering both *, and and neither worked.

1 Like

If I understand correct, the Load Balancing done with Rancher’s Ingress is basically the NGINX Ingress so we should be able to use the default certificate option defined here: