INSTALLATION FAILED: chart requires kubeVersion: < 1.25.0-0 which is incompatible with Kubernetes v1.26.0

Good day!
Try to install Rancher
Added the Helm Chart Repository rancher-latest
I get an error
Error: INSTALLATION FAILED: chart requires kubeVersion: < 1.25.0-0 which is incompatible with Kubernetes v1.26.0
Can you please tell me if there is a date when support will be implemented or is there a way to install to ignore versioning?
Thanks

Hey guys
I have the same problem
is there any solution?

change kubeVersion in Chart.yaml and it will be ok

I had a similar problem but with version 1.24.0. Downgraded helm from 3.9.3 to 3.7.2 and was ok.

Hi

Had the same problem. Solved it by downloading the helm chart to my local machine and edited the Chart.yaml file and made the following changes:

  • rancher
    kubeVersion: < 1.26.9-0

There is not a version of Rancher that can run on k8s 1.25+ yet
work in progress (mostly around PSP => PSA=
Rancher 2.7.0 works on 1.24 max

Same error. I’m using a Cloud-Init version of Ubuntu 22.04 in some Proxmox virtual machines which now delivers Kubernetes 1.26.1 version. How could I use Rancher in a production environment with those version discrepancies? I mean… should I use another cloud-init distro or something for safely run Rancher and stay “in sync” with the version supported?

Does it work without any issues?