Error install Rancher HA in K3s

Hi guys, when trying to install rancher HA using helm i got this error

“chart requires kubeVersion: < 1.20.0-0 which is incompatible with Kubernetes v1.20.0+k3s2”

As it says, the current version of Rancher does not support Kubernetes 1.20. Support will be added in an upcoming release.

curl | INSTALL_K3S_VERSION=v1.19.7+k3s1 sh - will install 1.19 instead.


Thank you so much …

Glad I came across this post.

I have just setup K3S with a load balancer, 2x master nodes, external MySQL database and 4x agent nodes. Everything seems to be work nicely.

I now want to install Rancher but I am also getting this error. I wasn’t aware I needed a specific version of K3S to work with Rancher. I’m hesitant to change the setup now as to be honest, having never done this before, I found it a bit of a pain to set up. All a learning curve I guess. I had never set up a load balancer or MySQL server before either so as you can imagine it took some time getting all the components working and then working together.

How far off is the upcoming release of Rancher that supports v1.20.2+k3s3? I’m not in a major rush to start using it and wondering if it may just be better to wait.

If I was to run that command above, as you have it printed now, will it overwrite the other settings I have setup in the current installation across my nodes? Or will that literally just downgrade the installation to that version and leave all the other configuration unchanged? I’m talking about taints, database and load balancer settings etc.

Any help or advice would be greatly appreciated.