Installation Script 404

When I run the following command I get a 404.

curl -sfL | sh -
[INFO]  finding release for channel latest
[INFO]  using v2.6.0 as release
[INFO]  downloading checksums at
[INFO]  downloading tarball at
curl: (22) The requested URL returned error: 404 

Sure enough the file is not there if I use cURL or just visit in a browser.

I am probably at fault somehow. Running this from Ubuntu.

Should this be opened as a bug on GH?

I have tried this on a few different VM’s and a physical laptop, just to be sure. I can’t imagine this is a legit bug, would there not be more noise around not being able to install Rancher on Ubuntu? I am brand new to this community and using Rancher, but it seems like more people would have run into this and it would already be fixed. That’s why I opened this here, in case someone can spot my mistake. Running the installer script as the docs say, not sure where I would be making the mistake, but you never know. :slight_smile:

They removed RacherD on 2.6+ currently. You’ll either need to manually set up a new Kubernetes cluster and install Rancher on top of it or use their Docker container for single-host Rancher setups.

Either way, I would highly advise not upgrading (yet, or at all) as the new version is very unpolished. It’s extremely slow (, the new UI misses many details/things that were on the old cluster manager, as you can’t scale deployments via it too.

1 Like

Thank you! I’ll manually set up a new cluster. I really appreciate your reply!