Rancher Helm Repo 404


I am trying to install Rancher using Helm Chart from an official repo


but it throws me 404 error. It also ocurres on stable repo.
I don’t see any other Helm Repo in docs nor in Google results. I didn’t find any status page for it.

Is it a temporary problem or it has been moved or deleted?


The documentation to install Rancher is located at https://rancher.com/docs/rancher/v2.x/en/installation/ha/helm-rancher/ and contains all the necessary steps to use the Helm chart to install Rancher. Can you describe what step doesn’t work and when it throws an error? Especially around those two steps:

helm repo add rancher-latest https://releases.rancher.com/server-charts/latest
helm install rancher-latest/rancher --name rancher --namespace cattle-system --set hostname=rancher.my.org

I know this document quite well. Everything is clear in it. Except this small issue, which I have describe :slight_smile: Simply request to


throws HTTP 404 error code.
Beeing more precise:

$ curl https://releases.rancher.com/server-charts/stable
<?xml version='1.0' encoding='UTF-8'?><Error><Code>NoSuchKey</Code><Message>The specified key does not exist.</Message><Details>No such object: releases.rancher.com/server-charts/stable</Details></Error>

Adding a Helm repo worked. updating too.
But I had a problem with install. Now it seems to work.
I tried to at least confirm this url is still in use.

It’s hosted on S3, there is no index on it. You can interact with the repo using helm commands. If you query a file directly you will get a proper response: curl https://releases.rancher.com/server-charts/latest/index.yaml

Helm would report an issue if it can’t retrieve the files, that would be the lead to an issue with the hosted repository.

Ok, now it is clear, thanks a lot.