Intel HD 4000 graphic / SLED 11 SP2

We are trying to get proper graphic support for Intel HD 4000 Ivy Bridge on SLED 11 SP2.

More or less we get OK support with our updated default installation, however we can’t get dual-screen mode working properly with 2 x 1920x1080 screens (max resolution on the second monitor is 1680x1050 connected through HDMI) and performance for more demanding graphic is relatively poor.

I can post more accurate performance test and details about hardware specifications and package versions tomorrow.

However I would like to know, if there should be any HD 4000 solution ready or planned for SLED 11 SP2.
I looks like I would fit in here:

As far as I can read in Intels documentation and elsewhere kernel 3.0 should be sufficient (we are on 3.0.51-0.7.9-default), but I am not sure?
I looks like an upgrade to Mesa version 8 (current 7.11.2-0.7.3) and xorg-x11-server to version 7.6 (current 7.4-27.68.1) is necessary, but how can this be done in a stable way on SLED 11 SP2?

I hope someone can lead us in the right direction on how we can get Intel HD 4000 Ivy Bridge working properly on SLED 11 SP2.

Please let me know if I should post any further information about our setup.

Thank you.

Kind Regards,
Kevin Peter Gade

hwinfo --gfx

10: PCI 02.0: 0300 VGA compatible controller (VGA)
[Created at pci.323]
UDI: /org/freedesktop/Hal/devices/pci_8086_162
Unique ID: _Znp.lwRqXGOuzh3
SysFS ID: /devices/pci0000:00/0000:00:02.0
SysFS BusID: 0000:00:02.0
Hardware Class: graphics card
Model: “Intel Ivybridge D GT2”
Vendor: pci 0x8086 “Intel Corporation”
Device: pci 0x0162 “Ivybridge D GT2”
SubVendor: pci 0x1297 “Holco Enterprise Co, Ltd/Shuttle Computer”
SubDevice: pci 0x4015
Revision: 0x09
Driver: “i915”
Driver Modules: “drm”
Memory Range: 0xf7800000-0xf7bfffff (rw,non-prefetchable)
Memory Range: 0xe0000000-0xefffffff (ro,non-prefetchable)
I/O Ports: 0xf000-0xf03f (rw)
IRQ: 42 (123137 events)
I/O Ports: 0x3c0-0x3df (rw)
Module Alias: “pci:v00008086d00000162sv00001297sd00004015bc03sc00i00”
Driver Info #0:
XFree86 v4 Server Module: intel
Driver Info #1:
XFree86 v4 Server Module: intel
3D Support: yes
Config Status: cfg=no, avail=yes, need=no, active=unknown

Primary display adapter: #10

What output do you see from the command xrandr?

Do the machine specs get that high a resolution for HDMI?

What output do you see from the command xrandr?

Do the machine specs get that high a resolution for HDMI?[/QUOTE]

I have searched for a solution for several hours before posting here but found the solution my self shortly after :wink:
But thank you for your fast reply.

Apparently the issue was due wrong registered monitors.

Selecting generic “–> LCD 1920x1080@60” for both primary and secondary monitor in Yast / Card and Monitor Properties solved the issue and we are running with 2 x full HD displays with proper graphic performance now. Haven’t needed to manually select monitor type for years so didn’t thought about that at first.

For now everything is good and we can move forward with this project - thank you.

PS. However I am not sure if newer versions of Xorg and Mesa and maybe other packages could improve performance with Intel graphics on SLED 11 SP2? We are going to stick with SLED 11 and Intel HD 4000 setup for several yours on other platforms as well and would like to improve performance as much as possible.

have you tried enabling sna in the /etc/X11/xorg.conf file in the device section?

Option "AccelMethod" "sna"

If it works, you should see something like;

cat /var/log/Xorg.0.log|grep sna

[    11.128] (**) intel(0): Option "AccelMethod" "sna"