IPv6 NIC UEFI boot fails for SLES11SP2

Has anyone tried Ipv6 NIC UEFI boot for Sles11sp2?
We are unable to get this done. Below are the configs that we have done to get this going.

  1. configured the PXE server for IPv6 boot. Below is the dhcpd6.conf file o/p
    default-lease-time 2592000;
    preferred-lifetime 604800;
    option dhcp-renewal-time 3600;
    option dhcp-rebinding-time 7200;
    allow leasequery;
    option dhcp6.name-servers 2000::1;
    option dhcp6.domain-search “pxetest.org”;
    option dhcp6.info-refresh-time 21600;
    option dhcp6.bootfile-url code 59 = string;

The subnet where the server is attached

(i.e., the server has an address in this subnet)

subnet6 2000:0:0:0::/64 {
option dhcp6.bootfile-url “tftp://[2000::1]/bootx64.efi”;

Nine addresses available to clients

(the tenth client should get NoAddrsAvail)

range6 2000:0:0:0::100 2000:0:0:0::2000;

Use the whole /64 prefix for temporary addresses

(i.e., direct application of RFC 4941)

range6 2000:0:0:0:: temporary;
prefix6 2000:0:0:0:: 2000:0:0:0:: /64;

  1. Connected the adapter port0 back-to-back to the PXE server. Emulex adapter supports IPv6 UEFI boot
  2. In the server setup, changed the boot settings to UEFI mode and selected the UEFI PXE boot protocol to IPv6.
  3. On the PXE client, client is able to acquire the dhcp6 ip address and download the NBP files, but after this when it has to download the rest of the installation files via TFTP, it fails saying no repository found even though the Sles11sp2 installation files are present in the PXE server.
  4. Elilo.efi file o/p is given below

append=“install=tftp://[2000::1]/sles11sp2/ ipv6only=1 insecure=1 sysrq=1”
#append=“install=nfs://’[2000::1]:/work/sles11sp264’ ipv6only=1 vga=791 manual=0 textmode=0 showopts sysrq=1”
We tried the transfer protocol as tftp and NFS. None of the methods seems to work.

All of the above methods work fine for IPv4.