Joining a domain

Hi all: I am a “domain membership on SLES” newbee and I need some help with getting an SLES server working properly with our domain. The server I need help with was recently rebuilt from OES 11 to SLES 11 due to zenworks incompatibility. I still need to be able to access this server’s storage over the network. When I browse the network from my Windows 7 computer the server does not show up and I cannot reach the server via \\servername. The server is in our DNS database.

So I joined the server to our domain successfully. I used the newer style domain notation rather than windows 2000/NT notation. I can see the server in now a member of the domain by looking at the domain members on one of our DCs. I have not enabled any other features such as “Also use SMB information for Linux Authentication” and “All users to share their directories”. NTP is configured and operating. The server does verify that it is a domain member. Under Samba configuration I have set the domain using the older style domain notation. It is not a DC controller. I have also set the NETBIOS name.

I would appreciate some help understanding what I did wrong and what I need to do to correct this. BTW, I tried this once before on a test server and it worked well. Not sure what I did different.

Thanks for the help, Chris.

I was able to join the domain and the server is now visible on the domain controller, but I do not see it when browsing the network from Windows.

Hi Chris,

just guessing: Maybe the SLES server’s NETBIOS name is not properly announced? Are the Win client (where you’re browsing the network) and the SLES server on the same IP subnet (-> IP subnet broadcasts from the SLES server will reach the Win client)? How’s the NETBIOS name resolution set up within your network - are you using WINS servers?