K3s (1.18.4) on RedHat doesn't work when SELinux is enabled

Hi All

I am running k3s on RedHat 7.x (tried also on 8.x) but see that all my pods (including kube-system)
can’t run.
When describe one of the pods I got:
Error: failed to create containerd task: OCI runtime create failed: container_linux.go:341: creating new parent process caused “container_linux.go:1923: running lstat on namespace path “/proc/40557/ns/ipc” caused “lstat /proc/40557/ns/ipc: no such file or directory””: unknown

Disabling SELinux solved the issue but I am looking to any other solution that will let me run SELinux + k3s
my k3s version is : k3s version v1.18.4+k3s1 (97b7a0e9)

BTW - it works on previous versions of k3s - no selinux issue on k3s version:
k3s version v1.0.1 (e94a3c60)

Please advise.


Can you give us the pod or deployment yaml for the pod that produces the above error?

all pods including kube-system pods …
After run k3s with --disable-selinux pods still didn’t started

I had to install selinux new version or disable it at all in order to succeed run all k3s pods properly.