K8s, RancherOS, Longhorn


#1

I spun up a simple 2-node k8s cluster on RancherOS 1.3 using rke. Tried provisioning longhorn, but the longhorn-manager container won’t start, throwing the following error:

ERRO[0000] Failed environment check, please make sure you have iscsiadm/open-iscsi installed on the host
FATA[0000] Error starting manager: Environment check failed: Invalid mount namespace /host/proc/1/ns/mnt, error Failed to execute: nsenter [–mount=/host/proc/1/ns/mnt mount], output nsenter: failed to execute mount: No such file or directory
, error exit status 1

I enabled the RancherOS open-iscsi service but that didn’t help. Is there an expectation that this should work?

Thanks!


#2

I have the same issue