Kubernetes and Ghost Catalog application

Hi folks. I’m new to Rancher so I hope this is not a dumb question. Congratulations on creating a platform that is so easy to use. Installing Kubernetes via the Rancher sandbox on my own AWS hosts was seamless.

I have no trouble deploying applications via the Kubernetes UI (uploading YAML files from https://github.com/kubernetes/kubernetes/tree/master/examples)

For whatever reason though, under the “KUBERNETES” / “Infrastructure Stacks” menu item in Rancher, “Add from catalog” does not seem to work as I would have thought.

For example if I attempt to add an Ghost deployment from the catalog (which appears to be Kubernetes ready) nothing happens.

I’ve tried other apps with the same result.

I fear this might be a dumb question but appreciate your help. The YAML files generated appear reasonable, so I’m not sure what is going on. If not an obvious answer I can upload the various files for closer inspection - ghost-service, ghost, mysql-service, mysql, rancher-compose.

Thanks in advance!