Kubernetes as rancher environment on top of rancheros: kubelet issue

Hi there,
As I found rancheros a very interesting operating system for running docker containers, I tried to base a rancher managed kubernetes environment on top of it.
After having booted my rancheros physical boxes, I launched rancher on the first box and then using the web gui I simply tried to add a new kubernetes environement.
Once the kubernetes environment created, I added 3 rancheros hosts.
Things started to deploy, but after a while, the kubelet containers seem to refuse to strart properly.
On each of the boxes the kubelet container log contains the same error :
10/12/2016 2:55:54 AMtime=“2016-10-12T06:55:54Z” level=error msg=“Failed to start (pid 34225) &libcontainer.Process{Args:[]string{“kubelet-start.sh”, “kubelet”, “–kubeconfig=/etc/kubernetes/ssl/kubeconfig”, “–api_servers=https://kubernetes:6443”, “–allow-privileged=true”, “–register-node=true”, “–cloud-provider=rancher”, “–healthz-bind-address=”, “–cluster-dns=”, “–cluster-domain=cluster.local”}, Env:[]string{“CATTLE_CONFIG_URL=”, “HOSTNAME=rancher”, “CATTLE_ACCESS_KEY=79FAF2CE085EA898AC4B”, “CATTLE_AGENT_INSTANCE_AUTH=Basic NzlGQUYyQ0UwODVFQTg5OEFDNEI6QlpOeXExdzJpeERkdFVlNW02ZkJ4aWs0RU1GVVBIbm9ITkFjNndSYg==”, “CATTLE_SECRET_KEY=BZNyq1w2ixDdtUe5m6fBxik4EMFUPHnoHNAc6wRb”, “PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin”, “PWD=/”, “SHLVL=1”, “HOME=/root”, “CATTLE_URL=”, “_=/usr/bin/share-mnt”, “OLDPWD=/etc/kubernetes/ssl”}, User:“0:0”, Cwd:”", Stdin:(*os.File)(0xc8200fc080), Stdout:(*os.File)(0xc8200fc098), Stderr:(*os.File)(0xc8200fc0a8), ExtraFiles:[]*os.File(nil), consolePath:"", Capabilities:[]string(nil), ops:libcontainer.processOperations(nil)}: [8] System error: pivot_root invalid argument"
10/12/2016 2:55:54 AMtime=“2016-10-12T06:55:54Z” level=fatal msg="[8] System error: pivot_root invalid argument"

Here are the version of pieces I am using :

rancheros 0.6.1
rancher latest version (as per docker images)
k8s v1.2.4-rancher9

As this is new for me, could you please help me to fix the issue I am encountering ?

hey @jerome I believe the docker version is too modern for k8s 1.2.4. If you ran rancher os 0.4.5, which comes with docker 1.10.3 , this should work for you.

Thanks for the information. I am going to downgrade to 0.4.5 and retry. I will let you know

Just to confirm it is actually running nice with rancheros 0.4.5.
Thanks again