Logentries on Rancher OS

I am investigating the use of Logentries. I have a RancherOS Vagrant instance and a RacherOS AWS instance and would like to know if there is anything I need to know that could cause issues with the Logentries container in a Rancher OS instance?

I don’t have specific experience with Logentries but based off of the documentation I believe it should work because they have a Docker container. Did you try this, did it work?

I have tried it with a RancherOS Vagrant instance - I am just trying some network configuration changes in the Vagrant box to see if that is my issue at this time. I have the logentries container running in the RancherOS and see it in the Rancher I have installed on it. Trying to determine if the network configuration is my issue.

Running this command:

docker run -d -v /var/run/docker.sock:/var/run/docker.sock logentries/docker-logentries -t [token] -j -a host=`uname -n`

I tried that with the networking through the host too using


…still no success.

I solved this issue - it was a noob problem. Nothing to do with Rancher OS. I had not configured the token correctly on the Logentries end. Set this up and used it with the Logentries container and now receiving logs. Onwards and upwards now with my RancherOS and Rancher exploration.

Great! I’m glad to hear that it’s working. :smile: