Monitoring etcd wit Rancher cluster monitoring

Hi folks,
I’m tiring to configure rancher cluster monitoring for get metrics from etcd server, k8s has bean deployed wit kuberspay ( etcd run in all master node on port 2379 ).
But i’m having same issue.

  1. When i try to turn on exporter-kube-etcd.enabled from globlal --> tools --> monitoring --> show advanced options ( left down corner ) --> add answer --> paste | exporter-kube-etcd.enabled=true
    It is ignored, other answer are working fine.
    prometheus.externalLabels.customers_name mycustomers_name

  2. if i try to update the deployment by cluster --> myverywellCluster --> system --> apps --> cluster-monitoring --> burgher-menu --> upgrade; i can turn on exporter-kube-etcd.enabled ( i know by itself is not enough to get etcd metrics in my scenarios)
    But after same time at the moment i don’t know what trigger this behavior, the default values for exporter-kube-etcd.enabled are restored ( from true to false ), other falg are not change.
    prometheus.externalLabels.customers_name mycustomers_name don’t change.

It is a bug it is a known and desired behavior, for cluster not deployed by Rancher ?


Hi all sameone, have same news about this topic ?