More guidance on starting proxy

I have a running rancher server cluster and started all the supporting services, etc. But it fails to add hosts in AWS. Maybe I need more insight in to the reverse proxy or some other detail to get hosts to complete the add process. Currently they just stick at the all most done phase in rancher, but never launch in AWS. I know the keys work, etc. Any thoughts?

Can you look in your rancher server logs to see if “go-machine-service” has started? If it’s automatically jumping from when you click to start to “Active” state (green bar in the host) and “Almost there…” in the text, then it sounds like go-machine-service hasn’t started properly.

Can you also share your server version?

Ok, it looks like your right go-machine-service isn’t starting correctly. I tried starting it on a rancher-server instance and on my webproxy instance. I can curl my rancher-server with the api keys I created so that seems ok. Where should the go-machine-server be run? and what do you make of these errors?time=“2015-09-18T20:05:08Z” level=error msg=“Failed to subscribe to events.” error=“websocket: bad handshake” subscribeUrl="wss://"
time=“2015-09-18T20:05:08Z” level=error msg=“Unable to start EventRouter” Err="websocket: bad handshake"
time=“2015-09-18T20:05:08Z” level=info msg="Exiting go-machine-service…"
time=“2015-09-18T20:05:21Z” level=info msg=“Setting log level” logLevel=info
time=“2015-09-18T20:05:21Z” level=info msg=“Starting go-machine-service…” gitcommit=102d311
time=“2015-09-18T20:05:21Z” level=info msg=“Initializing event router” workerCount=10

Ok, found my issue, when using Elastic Load Balancer in from of rancher-server, You have to use TCP to and fromport 80 and SSL (Secure TCP) to and from port 443 for the websocket support. Duh…forgot about that.

It maybe a good note for those setting up rancher in AWS to share this, it will save some pain.

“Unable to create EventRouter” Err=“Get EOF” new error, thoughts?

fixed that too, when you change your load balancer port it defaults your instance port to the same thing, instead of leaving what you previously had. I had to reset the instance ports to 8080 for TCP and Secure TCP.

Connection seems to be working better. Will update as I go.

time=“2015-09-20T11:04:11Z” level=info msg=“stderr: Error creating machine: There is already a keypair with the name test-rancher-host3. Please either remove that keypair or use a different machine name.” resourceId=1ph15

Error when I try to add a host, it creates the keypair, then errors saying that the keypair is already created.


When we add hosts through the UI, Rancher is just calling docker-machine. The error that you see is from docker-machine so unfortunately, I’m not too sure how to assist.

Does it happen all the time with any host name?

Yes, Would appreciate any thoughts.

Have you tried going into AWS and removing the key pair and then adding the host?

yes, several times, it keeps giving the same error.