Mount external hard drive

New to SUSE and running into multiple issues trying to mount an external hard drive for the “specially packaged version of SUSE Linux Enterprise Server for ARM”. Is there an easy way to do this? Apologies for the (hopefully) obvious question as I imagine this should be straightforward.

What I’ve tried:

  1. Trying to mount (same error with ntfs-3g):
    linux:~ # mount -t ntfs /dev/sda1 /mnt
    mount: unknown filesystem type ‘ntfs’
    linux:~ #

  2. What I’ve read I need ntfs-3g package installed, but I’ve tried looking all through the web and can’t find where to get this installed.
    zypper install ntfs-3g
    linux:~ # zypper install ntfs-3g
    Loading repository data…
    Reading installed packages…
    ‘ntfs-3g’ not found in package names. Trying capabilities.
    No provider of ‘ntfs-3g’ found.
    Resolving package dependencies…

Nothing to do.

  1. Tried downloading a few packages from the web, including a “one-click” link opened through yast but just errors abound


Hi and welcome to the SUSE Forums :slight_smile:
Normally, would suggest check out package hub first…

In this case, it’s off to check out the openSUSE Build Service (OBS for short) and see it’s available via the filesystems repository for aarch64, so rather than use one click, you can manually add via;

zypper ar -g -f -n "SLES12-SP2-RPI-filesystems" sles12-sp2-rpi-filesystems
zypper ref
zypper in ntfs-3g

You could disable the added repo, just in case it drags any additional packages not wanted.

zypper mr -d -R -p 101 sles12-sp2-rpi-filesystems

Then re-eanble if required.

Note: Hopefully the SLE SDK will get added one day soon, this does contain the ntfs-3g package…

Worked perfect, thank you!