Multiple NICs routing problem

Our SLES 11 has the following patchlevel:
SUSE Linux Enterprise Server 11 (x86_64)

We want to set up two NICs, one for our internal server network and one with a public IP-address.


Here is the problem:
When I set the default gateway to (network of eth0), can be reached from every network, e.g. my workstation network

BUT the public IP-address cannot be reached from any network except the itself. I used wireshark to ensure that my network traffic is reaching the server - which it does, but no echo reply is leaving the server, on any interface whatsoever.

If I switch the default gateway to, the same problem appears for the server network interface.

IP forwarding is enabled, even though it should not be necessary for this to work.

Any ideas?

Thanks, Mike

I solved it by setting
“net.ipv4.conf.all.rp_filter = 0” in /etc/sysctl.conf

[QUOTE=tgm_its;7042]I solved it by setting
“net.ipv4.conf.all.rp_filter = 0” in /etc/sysctl.conf[/QUOTE]

Hi Mike,

Thanks for feeding that back & good that you got it sorted.

That setting has bitten me with SLES 11 too (actually a newer kernel thing, no SLES as such).