Multiple public ip for an host


I have an agent-node with multiple public ip addresses. How can I do port mapping on the none default ip address ?

I tried specify the ip address inside the port address like but the gui doesn’t accept it.


Unfortunately, there is a bug that port mapping to a specific IP is not working right now.

We’re hoping that it will be fixed in an upcoming release.

Hello Denise,

I don’t see the issue number on your screenshot, is the issue solved ?

That’s a snippet the forum software automatically generates for Github links, not a screenshot. You can click on the issue name to to it. (spoiler: no it’s not added yet)

Hello Denise,

Have we made some progresso on that topic ? I watch the Github thread but I’ve seen a reference about refactoring the Rancher LB.

But just for my understanding, the capability to bind public IP addresses available on the host is for me not connected to the LB itself.

I use multiple IP addresses for multiple reasons like outgoing email flow, specific application without needed of a LB etc…

So is the issue link here still active and when it’ll be fixe we gonna be able to bind all ip addresses available on the host directly ?


When I first responded, I only looked at your desire to bind to a specific IP (which was the Github issue that I sent over).

I hadn’t fully read about the “multiple” part. There is a Github request for what I think you are looking for. Currently, there is no specific date for this request to be added into Rancher. We’re focusing on stabilizing Rancher for GA, which is coming at end of March.

Thanks for your feedback.

From my point of view it’s just an UI issue (with my light knowledge of rancher internal engine).

From my screenshot I just be able to do the docker equivalent of -p (if my right). Personnaly I don’t need that rancher know all ips on the main IF (of course it could be better) but as devops I know that is available and I just want to be able to use it.

Actually the UI forbid this kind of syntax in the PORT fields… So I’m pretty sure that my request is in link with the first issue isn’t it ?


Yes, if you’re just looking to do the equivalent of -p, then all you need is the first issue.