Nil public endpoint after cluster import

#1

I created a cluster with rke v0.1.11, then imported into rancher 2.1.1. Everything looks good, but when I deploy (say nginx), the url is http://%3Cnil%3E:30524/. The problem seems to be that the public endpoint is nil. I didn’t see any option to specify public endpoint(s) during import or afterward.

I created the cluster this way
vi my.yml
nodes:

  • address: node1.xx
    user: someone
    role: [controlplane,worker,etcd]
  • address: node2.xx
    user: someone
    role: [controlplane,worker,etcd]
  • address: node3.xx
    user: someone
    role: [controlplane,worker,etcd]

services:
etcd:
snapshot: true
creation: 6h
retention: 24h

./rke_linux-amd64 up --config my.yml

I created rancher this way (different machine from nodes)
docker run -d --restart=unless-stopped \

-p 80:80 -p 443:443
rancher/rancher

I ran the following to import
curl --insecure -sfL https://rancher.xx/v3/import/xsqvswzkcm22x9fnjrvmxmmjt6dwsxmhtvtdmtxvhfg5tggsrqx6jv.yaml | kubectl apply -f -

rancher and nodes are running ubunu 16.04.5 LTS and docker 17.03.2-ce

Appreciate any thoughts.

#2

I stumbled upon the same problem and a similar bug was also reported on github:


although it seemingly only occured with a HA-setup and worked fine with Single-Install.
But they don’t seem to have found a solution over there, either.

Assuming you’re notified about this reply:
Did you solve this problem or could you in any way work around it?