No longer able to connect to SMB shares on QNAP NAS devices

We have a QNAP NAS that offers multiple shares that are accessed by both Windows 10 and SLED 15 computers. A few months ago we developed an issue where the Linux machines could no longer connect to the shares through the Gnome file manager. When trying to access shares that previously worked we now get the following error:


The same error is generated by all of our Linux workstations when trying to access any share on the NAS. Windows devices can still access the share without error.

The NAS has the SMB encryption option selected which means that any clients must be able to use SMB3. An ‘out of the box’ SLED installation would not connect to these shares but by adding:

    client min protocol = SMB2_02
    client max protocol = SMB3

to smb.conf we were able to access them until the issue described above started. Can anyone offer any ideas for a resolution?


I have discovered, by looking at the QNAP log files, that a connection is successfully made to the share, i.e. the credentials are accepted, before the error above is thrown.