Old SUSE as VM on a CentOS 6 Host

I’m having problems getting the network working on an old version of SUSE (8.2) as a VM on a CenOS 6.8 machine.
When I try to ping any outside IP (even the host bridge) it will not work, or sometimes I get icmp replies with huge delays. Looking at the /var/log/messages file I notice the following message:

Kernel: NETDEV WATCHDOG : eth0: Transmit timed out
Kernel: eth0: Seting 100mbps full duplex based on auto-negotiated partner ability 05e1

Host Machine Information:
Dell PowerEdge R610 with a 4 port NIC (BCM5709)
CentOS 6.8 with kernel 2.6.32-642.1.1

The VM (Using KVM):
SuSE 8.2 with kernel 2.4.20-64
NIC: Bridged (vnet0) using driver rtl8139

Some of the things I’ve tried (not a full list):

  • force eth0 on the VM, em1 on the host and the switch port to 100/full
  • disable multiple services on both the VM and the host machine

-Will work if using Xen 4 but the problem is that I have to configure the VM to use 2 serial ports and Xen 4 will not permit that.
-Any other OS as VM (ie: CentOS, systemRescueCD (gentoo I think) will work.

Hopefully someone can help me.
thank you


It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

These forums are peer-to-peer, best effort, volunteer run and that if your issue
is urgent or not getting a response, you might try one of the following options:

Be sure to read the forum FAQ about what to expect in the way of responses:

If this is a reply to a duplicate posting or otherwise posted in error, please
ignore and accept our apologies and rest assured we will issue a stern reprimand
to our posting bot…

Good luck!

Your SUSE Forums Team

Hi Guy,

have you tried changing the model of the vNIF (in the KVM configuration of the VM), from rtl8139 to e1000 (I don’t know if a supporting driver exists for SuSE 8.2, though)