openssl ssl_connect:

After 8 days of a fresh SLES 12 SP4 install, I can’t update or access website, any other website works fine.

I am very new to SUSE but not linux, please be kind :wink:

I get error refreshing repositories and downloading updates. Curl error 35 openssl ssl_connect: ssl_error_syscall in connection to

I don’t know if it has anything to do with it, but at the same time sshd started to only accept connections from the server itself, all external ssh attempts which worked yesterday are rejected.

The firewall was disabled from the beginning, I even started up the firewall and enabled ssh, checked that the tcp port is open. Journalctl doesn’t show me any errors, nor /var/log/messages or y2log.

how do I debug in Suse sshd? when I try to run with systemctl it doesn’t pass the -d option to sshd and if I run the service from /sbin sshd returns that the port 22 is occupied; even though sshd is not running.

All help appreciated.


It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

These forums are peer-to-peer, best effort, volunteer run and that if your issue
is urgent or not getting a response, you might try one of the following options:

Be sure to read the forum FAQ about what to expect in the way of responses:

If this is a reply to a duplicate posting or otherwise posted in error, please
ignore and accept our apologies and rest assured we will issue a stern reprimand
to our posting bot…

Good luck!

Your SUSE Forums Team