php5-tidy missing from repos?

Once again I am back. :slight_smile:

We are trying to find php5-tidy in the repos or the included extensions for php, but we are not finding anything in the repos.

This seems to indicate that it was included with SLES 11 SP2 at least: https://www.suse.com/support/kb/doc.php?id=7000141 (knowing full well that is practically ancient history).

I’m curious if there is a plan to have php5-tidy available in the future or if I need to start really looking for alternatives for what I am doing on certain parts of the site I am hosting.

On 26/02/2015 20:44, boblmartens wrote:
[color=blue]

Once again I am back. :slight_smile:

We are trying to find php5-tidy in the repos or the included extensions
for php, but we are not finding anything in the repos.[/color]

Since it’s an extension for PHP which is available via the Web &
Scripting Module I’d expect any available PHP extensions to come via the
same route.
[color=blue]

This seems to indicate that it was included with SLES 11 SP2 at least:
https://www.suse.com/support/kb/doc.php?id=7000141 (knowing full well
that is practically ancient history).[/color]

php53-tidy version 5.3.17 is available for SLES11 SP3, provided via the SDK.
[color=blue]

I’m curious if there is a plan to have php5-tidy available in the future
or if I need to start really looking for alternatives for what I am
doing on certain parts of the site I am hosting.[/color]

I’ll ask SUSE whether this is deliberate or an omission.

HTH.

Simon
SUSE Knowledge Partner


If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below. Thanks.

[QUOTE=smflood;26627]On 26/02/2015 20:44, boblmartens wrote:
[color=blue]

Once again I am back. :slight_smile:

We are trying to find php5-tidy in the repos or the included extensions
for php, but we are not finding anything in the repos.[/color]

Since it’s an extension for PHP which is available via the Web &
Scripting Module I’d expect any available PHP extensions to come via the
same route.
[color=blue]

This seems to indicate that it was included with SLES 11 SP2 at least:
https://www.suse.com/support/kb/doc.php?id=7000141 (knowing full well
that is practically ancient history).[/color]

php53-tidy version 5.3.17 is available for SLES11 SP3, provided via the SDK.
[color=blue]

I’m curious if there is a plan to have php5-tidy available in the future
or if I need to start really looking for alternatives for what I am
doing on certain parts of the site I am hosting.[/color]

I’ll ask SUSE whether this is deliberate or an omission.

HTH.[/QUOTE]
Thanks. I do have the web & Scripting Module added, just missing tidy … both literally and figuratively.

I don’t know if it makes a difference but I have both the SDK and the Web & Scripting modules installed.

[QUOTE=smflood;26627]On 26/02/2015 20:44, boblmartens wrote:
[color=blue]

Once again I am back. :slight_smile:

We are trying to find php5-tidy in the repos or the included extensions
for php, but we are not finding anything in the repos.[/color]

Since it’s an extension for PHP which is available via the Web &
Scripting Module I’d expect any available PHP extensions to come via the
same route.
[color=blue]

This seems to indicate that it was included with SLES 11 SP2 at least:
https://www.suse.com/support/kb/doc.php?id=7000141 (knowing full well
that is practically ancient history).[/color]

php53-tidy version 5.3.17 is available for SLES11 SP3, provided via the SDK.
[color=blue]

I’m curious if there is a plan to have php5-tidy available in the future
or if I need to start really looking for alternatives for what I am
doing on certain parts of the site I am hosting.[/color]

I’ll ask SUSE whether this is deliberate or an omission.

HTH.

Simon
SUSE Knowledge Partner


If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below. Thanks.
------------------------------------------------------------------------[/QUOTE]

Hi
If you need it now, you can always grab the php5 src rpm and build
locally, it will have the package your after?


Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
SUSE Linux Enterprise Desktop 12 GNOME 3.10.1 Kernel 3.12.36-38-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below… Thanks!

[QUOTE=malcolmlewis;26693]Hi
If you need it now, you can always grab the php5 src rpm and build
locally, it will have the package your after?


Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
SUSE Linux Enterprise Desktop 12 GNOME 3.10.1 Kernel 3.12.36-38-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below… Thanks![/QUOTE]

The assumption we are working on now is to try and farm it out to the tidy cli and get back what we need. If we can get the php5-tidy package back, we will be happy with that. Just odd to see it in SLES 11 and now in SLES 12.

Another anecdote … openSUSE 13.2 has php5-tidy available from the repos. I write this knowing full-well that SUSE and openSUSE are not the same thing.

:slight_smile:

On 27/02/2015 12:38, Simon Flood wrote:
[color=blue]

I’ll ask SUSE whether this is deliberate or an omission.[/color]

The answer was a mixture of both. Now waiting to hear whether/how
customers can request this.

HTH.

Simon
SUSE Knowledge Partner


If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below. Thanks.

[QUOTE=smflood;26937]On 27/02/2015 12:38, Simon Flood wrote:
[color=blue]

I’ll ask SUSE whether this is deliberate or an omission.[/color]

The answer was a mixture of both. Now waiting to hear whether/how
customers can request this.

HTH.

Simon
SUSE Knowledge Partner


If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below. Thanks.
------------------------------------------------------------------------[/QUOTE]

Thanks for your help.

I’m also having trouble installing the following php modules in SLES 12

php-apc’
php-memcache
php-memcached
php-tidy

i’m fairly new to Linux environments.

Could anyone please help me on this.

Thanks in advance.
Nithin Liviero

did anyone find a solution to this, or get an official reply from Novell?