Problems attaching a new data disk on a Suse Virtual Machine


I loose a Suse 11 Virtual Machine after attacing a 2nd data disk. When I reboot it, the machine freezes and give no response.

I’ve downloaded the OS disk and created a new VM on my PC’s Hyper-V. The VM does nothing, after Lilo the screen turns black and nothing hapens.

I’ve created a new VM and when have attached the 2dn data disk the problem occurs again.

Please, how can I get some support about this bug? I need a Suse VM, may I wait a correction or try another cloud service?

I use to host my VMs in US East. The used images was ‘SUSE Linux Enterprise Server 11 SP3’. I always use the last version and Standard type. The first VM was configured about november’2014, and the second I used the 2015/01/27 release.

I’ve attached 2 empty disks in both situations, always with RW cache:

In the first VM:

  • 1st disk with 1023GB
  • 2nd disk with ~50GB

In the second VM:

  • 1st disk with 1023GB
  • 2nd disk with 1023GB

I’ve configured the first disk and worked in the VM. With them online I’ve attached the second disk and rebooted after configure fstab (pointing to /dev/disk/by-id/nnnnnnnnn). After this reboot the machine freezes.


I’ve tried to reproduce your issue, and I cannot at the moment, due to another issue. I tried four times to attach a disk to two instances in ‘East US’ region, and none of the disks attached properly to the VM.

I tried again in ‘West US’, and was able to successfully attach, format, and mount two 1023 GB disks as you described. Can you please try again in another region?

Hello bear454, thanks for your help!

I didn’t receive the alert, sorry my delay!

Did you reboot the machines? It was hanging on reboot.

I’ll try now to deploy another one too.

bear454, Success!

I’ve deployed a new VM with 2 data disks. After several reboots (via OS and via Azure Panel) everything went fine!

:~/> lsscsi
[0:0:0:0] disk Msft Virtual Disk 1.0 /dev/sda
[1:0:1:0] disk Msft Virtual Disk 1.0 /dev/sdb
[3:0:0:0] disk Msft Virtual Disk 1.0 /dev/sdc
[3:0:0:1] disk Msft Virtual Disk 1.0 /dev/sdd

Thanks for your time, your patience and your help!

Best regards

Good to hear this was resolved.

You mentioned you were using “/dev/disk/by-id/nnnnnnnnn” in fstab to mount disks. Note that on Azure, currently SCSI IDs may not be persistent if you resize the VM or if the VM is otherwise moved to another host. I would highly recommend you use the UUID of the file system to refer to the disks instead. This should be much safer, particularly if you intend to clone this system or configuration.

Hi szarkos

Thanks for your valuable advice!!

Best regards!