SuSE11sp3 server hangs on bootup - checking file systems

Have a SuSE11sp3 box that constantly hangs on bootup at step checking file systems. Machine is a virtual vmware server. Was recently updated with outstanding patches as well. Each time it boots now it stops at step checking file systems. Has anyone ever seen this before? Ended up having to revert back to snapshot to get it back online.

Still haven’t gotten anywhere with this issue. We ended up deleting the snapshot and taking a new one. Then we tried to do a reboot of the vm without applying any updates and it still hung on checking files systems. Stayed in that spot for over an hour. We then reverted back to the snapshot and the box was back online. This way we could at least rule out issue with any of the updates that were applied. At this point, this box can’t be rebooted so we need to figure out what is causing this issue. Other SuSE vm’s built at same time as this box, have all been updated and reboot without issue. Any help would be appreciated.

Hi jlewter,

have you tried booting into maintenance mode (IOW from some Linux installation / live system media) and to then run the fsck manually? Maybe this would show messages that might help identify the problem.

Single-user mode might eventually work, but I’d expect the system to try the fscks then as well, so you’d be stuck again.

While the system “hangs” - do you see disk activity (in other words, an active file system check) or does the system seem to idle?


Ended up cloning the vm to possibly do some of the things you mentioned, running fsck, etc, so we would be running against a system that was offline. I booted it again, it took about 40 minutes, but it finally booted. We applied updates the box and booted again and it booted normally timewise. Here is a snippet from the boot log:

fsck from util-linux 2.19.1
[/sbin/fsck.ext3 (1) – /] fsck.ext3 -a -C0 /dev/sda3
/dev/sda3: clean, 237386/6553600 files, 3105618/26214144 blocks fsck succeeded. Mounting root device read-write.
Mounting root /dev/sda3
mount -o rw,acl,user_xattr -t ext3 /dev/sda3 /root

At this time I guess we will just monitor.

EXT3 and most other file system types force a file system check every certain number of remounts. For ext3 the default is (I believe 25), see the man page of tune2fs for more details on how to configure that or at
It was set when the file system was created.

You can run the following command to check yours

tune2fs -l /dev/sda3

It will also show you how many remounts you have until it forces on the next reboot. If you trust yourself to run the fsck manually every once in a while you can turn it off or set it higher, but it is there to prevent issues. It is good practice to stagger different file systems so they don’t all have to run at once. 0 or -1 will turn it off.