Rancher 2 w/ Longhorn


#1

Hello,

I installed Longhorn in my Rancher 2 Kubernetes cluster using the deployment that was provided on the Longhorn Github. I’ve setup a Longhorn storage class, and attempted to provision the library’s MariaDB with that storage class. I’m able to provision the volumes automatically, however, the pods never start and are stuck at initializing. I get the following error in the Pod events:

Unable to mount volumes for pod “ghost-mariadb-0_ghost(f1b73101-9509-11e8-b5dd-7ad618bcd808)”: timeout expired waiting for volumes to attach or mount for pod “ghost”/“ghost-mariadb-0”. list of unmounted volumes=[data]. list of unattached volumes=[data config default-token-pvfdp]

Any ideas on what might be causing this?


#2

Sounds like your flexvolume plugin wasn’t in the right directory.

See: https://github.com/rancher/longhorn#volume-can-be-attacheddetached-from-ui-but-kubernetes-podstatefulset-etc-cannot-use-it


#3

@yasker this sounds about right. Where would I make the change globally for this?


#4

You would need to change the parameter FLEXVOLUME_DIR in the deployment yaml file.

You can take a look at our latest v0.3-rc 's document here.

We’ve release v0.3.0. See documents here.


#5

Hello Sheng Yang, the link points to v0.3-rc which is no longer available. Please change it to https://github.com/rancher/longhorn/blob/v0.3.0/


#6

On the blog post at https://rancher.com/blog/2018/2018-08-23-longhorn-v0.3.0-release/ some of the links also give a 404.

Please change the links pointing to v0.3-rc to v0.3.0-release


#7

Thanks @milovanderlinden ! We’ve fixed the broken links in the blog as well.