Rancher Agent cannot connect to Rancher Server


I tried to setup a rancher server as described in the “Getting started” section. I tried using my Ubuntu server as well as a Ubuntu VM - similar response. It is a blank system with docker 1.10.3.

The server started nicely. I can connect to the web-ui on the network. I can use the docker ip with port 8080 and 8081 on the host as well to reach the web-ui. Server works well.

Next I tried to add a host. I used the same system where the rancher server is deployed. I used the web-ui and entered the IP-address so that the CATTLE_AGENT_IP is inserted into the command.

The command is executed and the docker images starts and immediately exits. Docker ps -a shows STATUS Exited (1). I tried to restart the container manually - same response.

The Firewall seems to be set correctly. I get a 200 response when using curl to reach the server address.

I read in several forum postings that there are suppose to be three container for the agent. I only see one. I also have the sneaking suspicion that the agent container is closed before any log is written.

I also tried to add a host from the VM to my server - similar response.

Any hints for me?


Hey, Gerrit.

What happens if you strip off the “-d” from the agent start command line? Do you end up with something like what I’m seeing here:

Yes I get the same error.

Well…I’ve not yet found an answer but if I do I will share.

I found a workaround:
I updated my docker version to 1.11.0 using the apt sources for Ubuntu Wily while the ones for Ubuntu Xenial are not working yet (despite being published on the docker website). Hopefully things work better after the official release of Ubuntu Xenial. This might not be the perfect solution for an operations setup, but good enough for testing.

What version of Ubuntu are you using? Is it Ubuntu Desktop?


Yes it is Ubuntu Desktop 16.04 LTS.
Using docker-engine instead of docker.io fixes the issue.

Same here. Change from Ubuntu-packaged Docker to Docker-packaged Docker cleared things up.

Ubuntu 16.04’s packaging of docker is incompatible with older versions of Docker.