Rancher agent failed after reboot system

Hi !

Sorry for my english.
I expose my problem :

  1. I’ve installed successfuly rancher server with private registry.
  2. I’ve installed an agent rancher on my server (CentOS 7) and i’ve deployed two custom containers

At this moment, that’s work perfectly but, if i restart the service docker or if i reboot the system (my server), the container “network-services-network-manager-1” won’t start (always restart)

Logs of the container :

Code: System error

Message: mkdir /var/lib/docker/devicemapper/mnt/f68ad5c2af2526b26c771f2188c6485f143d99b164416d2f7aa423ee765076bb/rootfs/run/secrets: read-only file system

0: setupRootfs
Package: github.com/opencontainers/runc/libcontainer
File: rootfs_linux.go@41
1: Init
Package: github.com/opencontainers/runc/libcontainer.(*linuxStandardInit)
File: standard_init_linux.go@59
2: StartInitialization
Package: github.com/opencontainers/runc/libcontainer.(*LinuxFactory)
File: factory_linux.go@247
3: initializer
Package: github.com/docker/docker/daemon/execdriver/native
File: init.go@35
4: Init
Package: github.com/docker/docker/pkg/reexec
File: reexec.go@26
5: main
Package: main
File: docker.go@20
6: main
Package: runtime
File: proc.go@188
7: goexit
Package: runtime
File: asm_amd64.s@1998
Timestamp: 2016-12-22 17:45:51.250886808 +0100 CET
Code: System error

Message: mkdir /var/lib/docker/devicemapper/mnt/f68ad5c2af2526b26c771f2188c6485f143d99b164416d2f7aa423ee765076bb/rootfs/run/secrets: read-only file system

Thanks for advance.

Yes, there was an issue with restarting agents. This was addressed in v1.2.2.

Please try and upgrade and let me know if you still hit the issue.


I’ved resolve my problem by following this instruction :

Uninstall ur docker service and install this with use my previous link.

Best regards

I ran into this problem too. Are you suggesting to switch it on the docker run command?

sudo docker run -d --privileged -v /var/run/docker.sock:/var/run/docker.sock -v /var/lib/rancher:/var/lib/rancher rancher/agent:v1.2.0 https://rancher.myco.com/v1/scripts/79D301FABD1BEFD7AA9C:1483142400000:NzraAMCPF0fWq4ZTpeo3z

Am I being dim? I assume you’re referring to rancher/agent v1.2.2 but I can not find this. Please advise.

Denise was referring to Rancher 1.2.2, the agent has it’s own unrelated (but in this case close) version number.

Is this problem fixed in 1.2.2?
I ran into the same problem with Redhat 7.3 devicemapper storage and docker 1.12.6