Rancher cli hangs while removing stack


#1

Within a (scripted) Jenkins pipeline we execute a "rancher rm " command to clean up a already deployed stack.
We are facing the issue that the command does not return from its call and hangs.
We introduced a timeout in the Jenkins stage of 10 minutes and the command gets interrupted then (and the Jenkins pipeline failing due to an cattle exception).
The stack, however, gets deleted immediately.

We tried several versions of the rancher-cli. With version 0.6.3 and before this phenomenon does not occur at all. Beginning from version 0.6.4 (even until current version 0.6.13-rc1) of the rancher-cli it hangs.

Even outside a Jenkins context (running rancher rm from console) this behaviour is reproducible.

We also tried different ways for providing the parameters, namely using the cli.json and command line parameters (like --access-key, etc.).
When the authentication parameters get provided by cli.json the hanging phenomenon does not occur even with the newer versions.

Currently, we are running rancher 1.6.22 (with an on-premise cloud).

Any idea about this? Anyone experiencing similar phenomenon?