Rancher deployment on AWS - Load Balancer not working

I did a depployment of an RKE2 cluster on AWS using the option of “cloud provided” checked, and still, the Load Balancer is not created automatically when I deploy a service of that type. The external-ip is un “pending” status for ever, and the loadbalnacer is not created:

kubectl get svc
hello LoadBalancer 8080:30181/TCP 3m43s
kubernetes ClusterIP 443/TCP 135m

I trying to follow the documentation to fullfill the previous requirements and create a specific role with permission on AWS, but still not working, so not sure if I missing any particular step.I missing.

I created the policy “rancher_policy” and I assigned it to the role “rancher”, then I assigned that role “rancher” to all nodes that are created trough Rancher. Is there any other thing that should be done?


Without knowing too much about your setup, do you have the Amazon Load Balancer Controller (Welcome - AWS Load Balancer Controller) installed?
AWS lists that in their prerequisites for application/network load balancing in the EKS documentation.

1 Like

You aren’t clear if you are using EKS or not? If you are deploying to EKS, you must deploy your own nginx ingress, AWS does NOT install one by default. For on-premise rke2-provisioned clusters, it installs this by default. This is not clearly documented by SuSE!

You can find online resources on this, like this example Provide external access to Kubernetes services in Amazon EKS

No, sorry I was not clear on my post. I was doing the deployment on ECS nodes, I am not using EKS.

Hi, I am using rke2-provisioned clusters, but whenever I mark the option “cloud-provider” I have problems with the deployment on them. The cluster does not finish the deployment, even I already setup an AWS IAM Profile as suggested. After doing some more researching, I think is because I am not tagging correctly the rest of AWS resources, as the VPC, subnet or even nodes. I do not really understand why I should do that task my self and is not RANCHER the one who automatically adds that tagging. The instructions are very confusing, how I do known in advance the cluster-id to tag them ? Should not that tagging do automatically by the process ? I guess the reason why my deployment does not finish is that one, but not sure at all :.-(