Rancher Installation


I am a novice in terms of using Docker as well as Racher. I have a docker 1.9.0 image on Digital Ocean, and I installed 1.9.1.

When I tried installing Rancher, package has been downloaded correctly, but couldn’t proceed further because of the following error. Please help.

aufs au_opts_parse:1155:docker[1937]: unknown option dirperm1


I have destroyed the earlier image, and got a 1.9.1 and installed Rancher.

I still get the same error.

Could you give us more context, what commands were you running (exclude personal information) etc?


I followed the QuickStart Guide:

I used the following command:

sudo docker run -d --restart=always -p 8080:8080 rancher/server

I could not proceed beyond this.

What OS is the docker host? I am not familiar with digital ocean

Sorry for not being clear.

Ubundu 10.04.03 plus Docker 1.9.1

Sorry for the typo. It is 14.04.3

It seems you aren’t the only one, this is a docker issue not a rancher issue it seems:

Thank you. Which version would be the safest catch to install and try Rancher if 1.9.1 has issue ?

I couldn’t answer that, I have it running on 1.9.1 on Debian.

Apparently, Rancher is up despite this issue. Thanks for helping out.

This calls for a new Trouble shooting section.