Rancher NFS volume in "released" state

I’m testing Rancher 2.0 and have some trouble with nfs-volumes.
First, I added a persistent volume in my cluster storage settings and set the volume-plugin mode to nfs, then the volume state was set to “available” and I started adding a volume claim in one of my container. So far so good.
Later I tried to make a rollback to the container state without the volume claim and since then the volume state for the cluster is on “released” and I’m not able to create any more volume claims.

For testing purpose I deleted the storage volume (cluster menu) and added it again. This time I tried to add a volume in my cluster without a running container (in the default namespace menue in the volumes tab) and again it worked fine but when I deleted the volume in my namespace the cluster volume state changed to “released”.

Any idea what the released state means and how I can fix this without readding the whole cluster volume ?

Besides, it is extremly confusing, that the cluster volume and the volumes claims inside a namespace are called both volumes.

1 Like

I personally agree with you the term volume is getting over-used. I believe when I encountered a similar situation yesterday and I had to delete the volume and re-create it which doesn’t seem right at all. It would be nice to find a state transition diagram or list of how this is supposed to work.

The State Released is described by kubernetes with the following:

Released – the claim has been deleted, but the resource is not yet reclaimed by the cluster

Thanks for replying. But I dont understand how one volume claim can cause a complication with the whole storage volume. I was planing to bind a storage volume to the cluster and have then multiple volumes inside a container, just like in rancher 1.6 with the nfs module. If this is a kubernetes problem im not sure how to solve this, any suggestions ?

1 Like