Rancher openstack host creation erro

I tried to create the openstack vm on rancher i give following values as input in rancher ui , i am using openstack mitaka version

auth_url:http://192.168.54.191:5000/v3
availablity zone: nova
domain name: default
flavor name: m1.small(As in the openstack dashboard)
image name:ubuntu-14.04(As in the openstack dashboard)
keypair name: first-key
private keyfile :/home/user/first-key.ppk(Present in the rancher server VM not in container)
openstack region : RegionOne
SecGroup :default
openstack ssh user: ubuntu
openstack tenant name: demo
openstack user name : demo

when i see the rancher logs i see the following lines

time=“2016-09-26T11:11:23Z” level=info msg=“Purging Machine” eventId=3042aa01-1b77-4d83-9ba2-1a4b8ab1c41e resourceId=1ph44
time=“2016-09-26T11:11:23Z” level=info msg=“Machine purged” machineDir="/var/lib/cattle/machine/3edebf68-5f7c-429c-944c-10b9ab5d9fb5" machineExternalId=3edebf68-5f7c-429c-944c-10b9ab5d9fb5 resourceId=1ph44
time=“2016-09-26T11:34:52Z” level=info msg=“Creating Machine” eventId=76bff2eb-2405-4e45-9cfe-0a6c36cd486e resourceId=1ph45
time=“2016-09-26T11:34:52Z” level=info msg="Cmd slice: [create -d openstack --engine-install-url https://releases.rancher.com/install-docker/1.10.sh --openstack-active-timeout 200 --openstack-auth-url http://192.168.54.191:5000/v3 --openstack-availability-zone nova --openstack-domain-name default --openstack-endpoint-type publicURL --openstack-flavor-name m1.medium --openstack-image-name ubuntu-14.04 --openstack-insecure --openstack-ip-version 4 --openstack-keypair-name first-key --openstack-net-id 1e38358a-6c19-46cb-a323-a34d2206e7d6 --openstack-password password --openstack-private-key-file /home/user/first-key.ppk --openstack-region RegionOne --openstack-sec-groups default --openstack-ssh-port 22 --openstack-ssh-user ubuntu --openstack-tenant-name admin --openstack-username demo op]"
time=“2016-09-26T11:34:52Z” level=info msg=“stdout: Creating CA: /var/lib/cattle/machine/ffb0e83c-9adc-4430-ba64-9641f968696b/certs/ca.pem” resourceId: =1ph45
time=“2016-09-26T11:34:52Z” level=info msg=“stdout: Creating client certificate: /var/lib/cattle/machine/ffb0e83c-9adc-4430-ba64-9641f968696b/certs/cert.pem” resourceId: =1ph45
time=“2016-09-26T11:34:52Z” level=info msg=“stdout: Running pre-create checks…” resourceId: =1ph45
time=“2016-09-26T11:34:52Z” level=info msg=“stdout: Creating machine…” resourceId: =1ph45
time=“2016-09-26T11:34:55Z” level=info msg=“stdout: The default lines below are for a sh/bash shell, you can specify the shell you’re using, with the --shell flag.” resourceId: =1ph45
time=“2016-09-26T11:34:55Z” level=info msg="stdout: " resourceId: =1ph45
time=“2016-09-26T11:34:56Z” level=info msg=“starting cleanup…” machine name=op
time=“2016-09-26T11:34:56Z” level=info msg=“cleanup successful” machine name=op
time=“2016-09-26T11:34:56Z” level=error msg=“Error processing event” err=“exit status 1” eventId=76bff2eb-2405-4e45-9cfe-0a6c36cd486e eventName=“physicalhost.create;handler=goMachineService” resourceId=1ph45

could you please help me with these

Hello,

Even I am having the same issue. Can somebody tell me how to fix this.

Have you tried taking the cmd slice and using that to try and do a docker-machine create to see if you are able to create a machine. If that has no issues, please let us know.

Rancher is using docker-machine to provision hosts through the UI.

hi denise it seems a problem with tenant name , i used tenant id instead of tenant name it works now i am able to provision the host , thanks for your help, i will let you know if there any errors in the furure,

Thank you