Rancher UI master branch fails to start


I have followed the instructions as per rancher/ui README.md to start the ui.

After i type npm start I see warnings

DEPRECATION: Addon files were detected in `/home/ram/code/megam/nodejs/obcui/node_modules/ember-load-initializers/addon`, but no JavaScript preprocessors were found for `ember-load-initializers`. Please make sure to add a preprocessor (most likely `ember-cli-babel`) to in `dependencies` (NOT `devDependencies`) in `ember-load-initializers`'s `package.json`.

The UI doesn’t appear in 57, 54 versions of chrome and firefox 52 version.

I use Archlinux with Node (7.7), I have tried in Node 7.4, 6.9, 4.8.
I had my colleague try it out in Ubuntu 16.04 (Node js 6).

The error i see in the console of my browser is

You almost definitely want 1.5-fixes right now, master is heavily WIP for 2.0.

But this specific problem is caused by ember-cli 2.12, take the caret (^) out of the line in package.json and re-npm install.

Ok. thanks.

That worked.

I tried 1.5.1fixes as well. But anyway its good now.

Thanks for your help.