Rancher UI Split

Rancher server v1.1.4
Rancher ui v1.1.14

I’m splitting the static UI apart from the server to make some cosmetic changes, and I can’t seem to get the server to load it correctly.

I’m using an nginx container to host the static files, which I create using the instructions on the rancher/ui GitHub.

./scripts/build-static -l -c ‘your-server.com

I’ve tried that command using the -c flag and without. Is that flag absolutely necessary?

When I launch the container, and edit the /v1/settings/api.ui.index setting, nothing seems to load correctly. I’ve attached a screenshot of what I see. Looking at the logs it seems like the index.html is pulled but nothing else can be loaded. From the screenshot it also seems like the screen being pulled is the 1.2/1.3 environment screen, when the server version is 1.1.

Appreciate the help.

-c sets the URL that the assets are expected to be loaded from, which goes into the index.html. If you’re running your own UI and want 1.1 you’ll want to use https://github.com/rancher/ui/tree/1.1-fixes ; Master is for the current or next release.

Thanks for responding Vincent.

I pulled the 1.1.14 tag from Git, so you’re saying I should be using a different branch altogether? When I compare the branches, it seems like v1.1.14 is up to date with 1.1-fixes, so I’m not sure what to use as a base.

The tag is fine, it just sounded like you were pulling master since you said it looks like 1.2/1.3 instead of 1.1.

OK thanks. So I’ve made a bit of progress, but I still can’t get my server to load my UI. I built the static binaries with the same command, this time using -c ‘10.x.x.x:8000/1.1.14/’. The screen shot below shows what I’m seeing now. Not sure what’s causing this.

You have no translation files… The entire build output has to be hosted on the matching url.

I’m following the instructions as-is from the Git page, so I’m not sure how I’m missing those files. I run the build-static command, then copy the 1.1.14 folder into my httpd container. It contains the translations folder, even while the container is running.

-c shouldn’t include the version. You’re going to have to look at what the browser is requesting in dev tools vs what is on your http server and what is being sent back. I can’t tell you much blind, but that picture shows the basic CSS/JS loading but all the references to translations and fonts broken. So the path they’re being requested with is wrong (and -c including the version would do that) and/or the files are not where they should be.

Working off of what is basically an 8-month old version also doesn’t help either, though it worked at the time. This script is how all the real builds are generated and published, and there’s nothing really special about our CDN.

Hi all,
I have also created some enhancements to the UI and now want to deploy those enhancements as remote hosted package.
But I’m not clear about the general design here.

I’m currently using rancherui 1.5.7

Now my questions:

Thank you so much for the great product !