Redis remove stuck

Hi all,
I’ve installed the redis server from the Catalog app. Now I’m trying to remove it but seems to be stuck.

but the app seems to waiting for “foregroundDeletion”.

I tried many times to relaunch the removal process but doesn’t work.
what could I do to remove this app?
thank you very much

Same issue here withe another longhorn catalog app.

When I reinstalled it (after trying latest dev version), the storage class longhorn was already there so the deploy did install everything but was marked as failed.

So I wen and tried to delete it to reinstall it clean. Never managed to delete it. Seems as long as the catalog app deployment fails, you can’t remove it.

the old one is not running anything, it is just there reserving the name and I can’t get rid of it.
So i had to rename the new longhorn install app as longhorn-new…

This is very annoying… :frowning:

Is there any API command or kubectl edit command to remove those stale apps ?

Many thanks in advance!

@nick76 @Teknologist Did you manage to do something about it ? I have the exact same bug, but some pod won’t delete.

hi ml2…
onestly the pods that were stuck in removing disappeared once I rebooted the servers after a yum update.

@nick76 It seems to be a known bug. Here the issue: