Resizing the primary partition on the Raspberry Pi

Does anyone have working steps to get the Raspberry Pi image (0.5.0) to expand to fill rest of the SD card?

[edit: Looks like the issue here:]

I have tried to use the sudo ros config set cloud_init.rancher.resize_device dev/mmcblk0p2 as an attempt to set the setting in cloud_init and then reboot, but to no avail. Not sure based on the documentation if that is the right way or not to “update” the cloud init file.

There is a bug that is affecting AMIs. Could the resize_device be broken in general?

Attempted the manual application of the resize commands, but the resize2fs fails with device busy.

growpart /dev/mmcblk0 2
part probe
resize2fs /dev/mmcblk0p2

Attempted the raspberry method for expanding an partition, same resize2fs issue with device busy.

sudo fdisk /dev/mmcblk0
... disk commands to delete and recreate partition ...
sudo shutdown -r now
sudo resize2fs /dev/mmcblk0p2
1 Like

The resize_device setting doesn’t work for Raspberry Pi, which is why that issue was filed.

I tried to get it working manually but I ran into the same issue as you. Unfortunately, I haven’t had the time to work through it and figure out a workaround yet.

Has there been any update on this?
I’m having the same problem and I’ve exhausted all options really :confused:

It seems there are new official instructions So I will try it later. But I can see there are a lot of steps to do it. This seems not very useful, imagine I want to create an infrastructure of 100 raspberry Pi where I want to deploy software automatically.

With new instructions, now we have space to run containers (I have suggested to put step 10 previous to step 8).

Now my intention is to run a rancher-agent, but the problem is (I guess) there is no ARM images of rancher agent :frowning:

Status: Downloaded newer image for rancher/agent:v1.0.1
docker: Error response from daemon: rpc error: code = 2 desc = "oci runtime error: exec format error".

I have seen other threads about this, and a guy called withinboredom trying to create these arm images. Any suggestion about that? Is there an official attempt to support RAncher in Raspberry?