Rke without internet


I’d like to setup a kubernetes engine using rke but none of the servers can reach Internet.
To get all images to run kube, I need to use a rregistry proxy provided by nexus.

Is there a way to force RKE to use nexus as source registry ? I have found some documentation on rancher to globally set a custom registry, but nothing on RKE. For now I do not use rancher.


Rancher Docs: System Images lists needed images and has a couple of sentences about air gap setup. Did that not work or was something specific unclear about it? You do need to follow the link about private registries for the full info on there and there’s more info about air gap setup there.

I’ve seen their docs be out of date in ways that make them not work exactly, but I’d imagine that it’ll still be close even if they are out of date (which seems less likely with RKE1).

sorry for the long reply.

Thanks for this page. I was searching with “use a custom registry” and no air gap setup.

I will try it asap !!!