Samba DenyMode DENY_READ

Building a new system. We have tried turning every locking setting to off in smb.conf but we still see DENY_READ when users’ software asks to lock files. This results in others users being unable to also read the file simultaneously. We overrode this behavior on a previous system only using locking = no.

locking = no
workgroup = SHORT
netbios name = %L
name resolve order = lmhosts hosts wins bcast
security = ADS
auth methods = winbind
password server = dmcontroller1 dmcontroller2
max log size = 500
max xmit = 65535
os level = 0
preferred master = No
local master = No
domain master = No
ldap ssl = no
winbind use default domain = yes
winbind nested groups = yes
winbind separator = +
comment = %h (Samba %v)
hosts allow = 192.168.1. 192.168.2.
hide dot files = No
host msdfs = No
syslog = 3
username map = /etc/samba/smbusers

path = /path/to/share
read only = No
directory mask = 0775
force group = mygroup
case sensitive = No
vfs objects = full_audit
full_audit:prefix = ^%h^%T^%u^%g^%U^%G^%D^%I^%m^%M^%S
full_audit:success = mkdir rename unlink rmdir open close chmod chown
full_audit:failure = mkdir rename unlink rmdir open close chmod chown
full_audit:facility = LOCAL7
full_audit:priority = NOTICE

The samba versions are identical between the working and non-working systems:


It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

Has your issue been resolved? If not, you might try one of the following options:

Be sure to read the forum FAQ about what to expect in the way of responses:

If this is a reply to a duplicate posting, please ignore and accept our apologies
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your SUSE Forums Team